Android phone won’t connect

Home Forums DIY Sand Table Android phone won’t connect

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #859
    klwill1192
    Participant

    I have finished building and testing the hardware and firmware, and everything seems to be working correctly. I can connect to the SandBot through my local WiFi with my laptop and my iPad and control it using both the cnc and sand UIs. However, I cannot get my Android phone to connect to the SandBot. I have tried using Chrome and the SandBot app, but neither one can connect. I Chrome I get these error messages:

    This site can’t be reached
    http://192.168.0.18/ is unreachable.
    ERR_ADDRESS_UNREACHABLE

    I have verified that my phone is connected to the same SSID as the SandBot. I don’t see any obvious firewall rules on my router that might be causing a problem. I’ve power cycled my router, my phone, and the SandBot. I’ve disabled and re-enabled WiFi on my phone.

    It seems to be specific to my phone since my iPad and laptop both can connect successfully. Android doesn’t really give me many WiFi settings to play around with, so I’m kind of at a loss on how to proceed.

    Does anybody have any ideas?

    #861
    Matt G
    Keymaster

    This is a tough one.. Normally I’d think it was some wifi setup issue, but if your ipad and laptop can both see the sand bot, then it’s gotta be an issue on the phone. I haven’t seen this before, but if this happened to me I would try some of the following…

    – Is your phone IP address on the same subnet? I would assume so, but always worth checking the IP. Maybe compare it to the ipad and laptop and see if it’s some different range of IPs
    – 2.4 vs 5Ghz bands – are both the devices on the same band? I believe the huzzah is 2.4 only, so try connecting your phone to the same band. (Not that this is needed – but would be worth it for troubleshooting)
    – Are you running any private DNS on your android phone for ad blocking?
    – Download a terminal emulator app and attempt to ping the sand bot

    See if any of those lead to some lead at all…

    #862
    klwill1192
    Participant

    Thanks for the suggestions. I had already verified the subnet and tried connecting my phone to both the 2.4GHz and 5GHz bands without success. I had also installed a network app that has ping capability and showed all devices on the LAN. No joy.

    So this morning I powered down the router, phone, and SandBot all at the same time, then powered them all back on. Now it’s working (though the app doesn’t show the amount of storage on the SandBot–I have successfully formatted and installed a 32GB card).

    On an unrelated note–does a 3-foot table really require 10 pounds (5 bags) of sand? Sisyphus recommends 3 12oz bags of sand for their 3-foot tables.

    On another unrelated note–do you know if anyone downloaded the full Sisyphus BOX folder of designs before they took it offline?

    Thanks for all the work you and Rob have put into designing, building, and documenting these tables. I can’t wait to start the carpentry work on mine.

    Kevin

    #863
    Matt G
    Keymaster

    Yea good call on reminding me about the app not showing the storage correctly – I forgot about that issue.

    The amount of sand you use depends on how “deep” you want the tracks to be.. I think I used 4-5 bags to get a nice even thickness across the whole table.

    I wish I would have saved the old sisyphus dropbox before it went down. I got a lot of my tracks from there. I am not aware of anyone that has an archive. I also tried to get the default sisyphus tracks from the sisbot rpi image without any luck.

    I posted lots of links to tracks in one of the comments on the main post, but here they are.

    The sisysphus subreddit is a decent community, although it’s not very active. I’ve gotten some cool patterns from here
    https://old.reddit.com/r/SisyphusIndustries/

    markyland posts some good stuff.

    This guy makes some of my favorite tracks. I love some of the crop circles, and hosta is great. StarryNight is very cool too – looks like the actual painting
    https://github.com/ddkengr/Sisyphus-threads

    This guy creates some nice ones – there are preview images
    https://github.com/Dithermaster/sisyphus/tree/master/thr_paths

    Another guy’s dropbox
    https://www.dropbox.com/sh/yd5a5v37c6bz2sd/AAD9m1W7lSUnSixx5ZjfZeWFa?dl=0

    I also run some of these patterns
    https://github.com/heropup/sisyphus

    I like this guys’ spirals and run a few of them
    http://thejuggler.net/sisyphus/

    Sisyphus actually has a new community tracks section. I haven’t really browsed this yet, but should be a good source of thr files
    https://sisyphus-industries.com/community/community-tracks/

    There is also a sisyphus public dropbox somewhere that I used to go to .. I can’t seem to find the link anywhere although it’s referenced a lot on reddit and the sisyphus forums

    This website apparently lets you make your own from an image. I’m not sure how well it works
    https://sftrou.omarelamri.me/#/home

    Sandify lets you create parametric patterns and export the thr files
    https://sandify.org/

    • This reply was modified 2 months ago by Matt G.
    #865
    klwill1192
    Participant

    I ordered 4 pounds of sand. I’ll see how much coverage that gives me and go from there.

    Thanks for re-posting the links. I don’t think the Sysiphus public drop box exists anymore. I’ve seen a few links posted, but they’re all dead. I’ve checked out the new community tracks section, and it looks promising. I should probably start learning to make my own.

    Thanks again.

    Kevin

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.