Changing between “sand” UI and “cnc” UI

Home Forums DIY Sand Table Changing between “sand” UI and “cnc” UI

Tagged: , ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #771
    GedK
    Participant

    I followed Matt’s guide on setting up/configuring the SandBot and was successful in opening up the cncUI with my robot’s IP address. I then copy&pasted his json configuration into the RobotConfig area and was able to get my robot moving when I clicked the “Home All” button. After all the excitement of my Sandbot’s first steps, I remembered seeing a prettier UI on Rob’s software revamp post. Reading through the post’s comments I saw a user named “Dan” had the same issue of the cncUI being displayed instead of Rob’s pretty sandUI. Dan’s fix was selecting a RobotType from the drop down menu who’s webUI was specified as “sand” in the “RobotConfigurations.cpp” file (any of the “SCARA” options). Looking at my pasted json configuration code, I noticed that Matt had made a small type-o and wrote “webui”: “SandUI” instead of “webui”: “sand“. Once I corrected the webui type, saved my config, and reset the robot, I was happily greeted by Rob’s sandUI browser! Unfortunately for me, I had not fine tuned my homing sequence nor gotten an SD card to work, so I am now stuck with a UI that does not let me live-edit my json configuration or view SD storage. I have very little experience in programming so I’m struggling to figure out how to go back to the cncUI or edit the active json configuration on the platform build.

    If someone could please direct me to the section in the code where I can find/edit my “saved” json configuration I would greatly appreciate it!!!

    #773
    RickG
    Participant

    Open a new web page similar to this but with the IP address of your table. http://192.192.1.1/cnc.html

    #775
    GedK
    Participant

    I didn’t think it would be that simple, but it worked! Thanks @RickG

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.