Error when compiling

Home Forums DIY Sand Table Error when compiling

Tagged: 

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #662
    hoopty
    Participant

    Hi Matt,

    I tried to compile the code downloaded from Rob which I guess is the same code for you and it will not compile. there seems to be an error in the module. I uploaded the error but it is not displayed here so I am unsure that you got it

    Let me know.

    • This topic was modified 7 months ago by hoopty. Reason: type o
    #664
    hoopty
    Participant

    Compiling .pio\build\featheresp32\lib489\AsyncMqttClient\AsyncMqttClient\Packets\UnsubAckPacket.cpp.o
    In file included from C:/Users/b1dx9/.platformio/packages/framework-arduinoespressif32/tools/sdk/include/lwip/lwip/ip_addr.h:43:0,
    from C:/Users/b1dx9/.platformio/packages/framework-arduinoespressif32/tools/sdk/include/tcpip_adapter/tcpip_adapter.h:24,
    from C:/Users/b1dx9/.platformio/packages/framework-arduinoespressif32/tools/sdk/include/esp32/esp_event_legacy.h:23,
    from C:/Users/b1dx9/.platformio/packages/framework-arduinoespressif32/tools/sdk/include/esp_event/esp_event.h:26,
    from C:/Users/b1dx9/.platformio/packages/framework-arduinoespressif32/tools/sdk/include/esp32/esp_event_loop.h:22,
    from C:/Users/b1dx9/.platformio/packages/framework-arduinoespressif32/libraries/WiFi/src/WiFiGeneric.h:27,
    from C:/Users/b1dx9/.platformio/packages/framework-arduinoespressif32/libraries/WiFi/src/WiFiSTA.h:28,
    from C:/Users/b1dx9/.platformio/packages/framework-arduinoespressif32/libraries/WiFi/src/WiFi.h:32,
    from src/main.cpp:58:
    C:/Users/b1dx9/.platformio/packages/framework-arduinoespressif32/tools/sdk/include/lwip/lwip/ip4_addr.h:79:37: error: expected ‘)’ before numeric constant
    #define IPADDR_NONE ((u32_t)0xffffffffUL)
    ^
    C:/Users/b1dx9/.platformio/packages/framework-arduinoespressif32/tools/sdk/include/lwip/lwip/inet.h:71:29: note: in expansion of macro
    ‘IPADDR_NONE’
    #define INADDR_NONE IPADDR_NONE
    ^
    lib/RdUtils/Utils.h:26:32: note: in expansion of macro ‘INADDR_NONE’
    static const unsigned long INADDR_NONE = ((unsigned long)0xffffffff);
    ^
    Compiling .pio\build\featheresp32\lib387\ESP32Servo\ESP32PWM.cpp.o
    Compiling .pio\build\featheresp32\lib387\ESP32Servo\ESP32Servo.cpp.o
    *** [.pio\build\featheresp32\src\main.cpp.o] Error 1
    ===================================================== [FAILED] Took 4.91 seconds =====================================================
    The terminal process “C:\Users\b1dx9\.platformio\penv\Scripts\platformio.exe ‘run'” terminated with exit code: 1.

    Terminal will be reused by tasks, press any key to close it.

    #665
    geri
    Participant

    Hallo sie müssen auf die Version von Plattformio achten, benutzen sie die ältere wie Matt im Video lg

    #666
    hoopty
    Participant

    Danke, aber woher bekomme ich es?

    #667
    hoopty
    Participant

    I dropped to 2.2.1 like in the video and it changed but still no joy.

    Compiling .pio\build\featheresp32\libcc9\WiFi\WiFiSTA.cpp.o
    In file included from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\lwip/lwip/ip_addr.h:43:0,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\tcpip_adapter/tcpip_adapter.h:24,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\esp32/esp_event_legacy.h:23,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\esp_event/esp_event.h:26,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\esp32/esp_event_loop.h:22,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiGeneric.h:27,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.h:28,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFi.h:32,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.cpp:25:
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\lwip/lwip/ip4_addr.h:80:1: warning: “/*” within comment [-Wcomment]
    /** 127.0.0.1 */
    ^
    Archiving .pio\build\featheresp32\lib969\libESP Async WebServer.a
    Archiving .pio\build\featheresp32\lib0eb\libArduinoLog.a
    Compiling .pio\build\featheresp32\libc20\AsyncMqttClient\AsyncMqttClient\Packets\ConnAckPacket.cpp.o
    Compiling .pio\build\featheresp32\libc20\AsyncMqttClient\AsyncMqttClient\Packets\PingRespPacket.cpp.o
    Compiling .pio\build\featheresp32\libc20\AsyncMqttClient\AsyncMqttClient\Packets\PubAckPacket.cpp.o
    Compiling .pio\build\featheresp32\libc20\AsyncMqttClient\AsyncMqttClient\Packets\PubCompPacket.cpp.o
    Compiling .pio\build\featheresp32\libc20\AsyncMqttClient\AsyncMqttClient\Packets\PubRecPacket.cpp.o
    Compiling .pio\build\featheresp32\libc20\AsyncMqttClient\AsyncMqttClient\Packets\PubRelPacket.cpp.o
    Compiling .pio\build\featheresp32\libc20\AsyncMqttClient\AsyncMqttClient\Packets\PublishPacket.cpp.o
    Compiling .pio\build\featheresp32\libc20\AsyncMqttClient\AsyncMqttClient\Packets\SubAckPacket.cpp.o
    Compiling .pio\build\featheresp32\libc20\AsyncMqttClient\AsyncMqttClient\Packets\UnsubAckPacket.cpp.o
    Compiling .pio\build\featheresp32\lib198\ESP32Servo\ESP32PWM.cpp.o
    Compiling .pio\build\featheresp32\lib198\ESP32Servo\ESP32Servo.cpp.o
    In file included from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\wifi_provisioning/wifi_provisioning/wifi_config.h:18:0,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\wifi_provisioning/wifi_provisioning/manager.h:20,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiGeneric.h:31,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.h:28,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFi.h:32,
    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.cpp:25:
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.cpp: In member function ‘bool WiFiSTAClass::config(IPAddress, IPAddress, IPAddress, IPAddress, IPAddress)’:
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\lwip/lwip/inet.h:71:29: error: ‘IPADDR_NONE’ was not declared in this scope
    #define INADDR_NONE IPADDR_NONE
    ^
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.cpp:288:56: note: in expansion of macro ‘INADDR_NONE’
    if(local_ip != (uint32_t)0x00000000 && local_ip != INADDR_NONE){
    ^
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\lwip/lwip/inet.h:71:29: error: ‘IPADDR_NONE’ was not declared in this scope
    #define INADDR_NONE IPADDR_NONE
    ^
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.cpp:324:48: note: in expansion of macro ‘INADDR_NONE’
    if(dns1 != (uint32_t)0x00000000 && dns1 != INADDR_NONE) {
    ^
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\lwip/lwip/inet.h:71:29: error: ‘IPADDR_NONE’ was not declared in this scope
    #define INADDR_NONE IPADDR_NONE
    ^
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.cpp:330:48: note: in expansion of macro ‘INADDR_NONE’
    if(dns2 != (uint32_t)0x00000000 && dns2 != INADDR_NONE) {
    ^
    *** [.pio\build\featheresp32\libcc9\WiFi\WiFiSTA.cpp.o] Error 1
    ===================================================== [FAILED] Took 4.44 seconds =====================================================
    The terminal process “C:\Users\b1dx9\.platformio\penv\Scripts\pio.exe ‘run'” terminated with exit code: 1.

    #668
    hoopty
    Participant

    I dropped to 2.2.1 like in the video and it changed but still no joy.

    from C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.cpp:25:
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.cpp: In member function ‘bool WiFiSTAClass::config(IPAddress, IPAddress, IPAddress, IPAddress, IPAddress)’:
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\lwip/lwip/inet.h:71:29: error: ‘IPADDR_NONE’ was not declared in this scope
    #define INADDR_NONE IPADDR_NONE
    ^
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.cpp:288:56: note: in expansion of macro ‘INADDR_NONE’
    if(local_ip != (uint32_t)0x00000000 && local_ip != INADDR_NONE){
    ^
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\lwip/lwip/inet.h:71:29: error: ‘IPADDR_NONE’ was not declared in this scope
    #define INADDR_NONE IPADDR_NONE
    ^
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.cpp:324:48: note: in expansion of macro ‘INADDR_NONE’
    if(dns1 != (uint32_t)0x00000000 && dns1 != INADDR_NONE) {
    ^
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\tools\sdk\include\lwip/lwip/inet.h:71:29: error: ‘IPADDR_NONE’ was not declared in this scope
    #define INADDR_NONE IPADDR_NONE
    ^
    C:\Users\b1dx9\.platformio\packages\framework-arduinoespressif32\libraries\WiFi\src\WiFiSTA.cpp:330:48: note: in expansion of macro ‘INADDR_NONE’
    if(dns2 != (uint32_t)0x00000000 && dns2 != INADDR_NONE) {
    ^
    *** [.pio\build\featheresp32\libcc9\WiFi\WiFiSTA.cpp.o] Error 1
    ===================================================== [FAILED] Took 4.44 seconds =====================================================
    The terminal process “C:\Users\b1dx9\.platformio\penv\Scripts\pio.exe ‘run'” terminated with exit code: 1.

    #669
    geri
    Participant

    Beim installieren in vs Code kanst du die Version auswählen

    #670
    geri
    Participant

    ok sorry ich denke du must die gleiche version bei espressif32 haben wie matt in seinem video

    • This reply was modified 7 months ago by geri.
    #672
    hoopty
    Participant

    Meinst du Kerndateien?

    #673
    geri
    Participant

    Du Must vs Code runterladen dann Plattformio und dann in Plattformio espressif32 Downloaden und da Must du auf die Version achten

    • This reply was modified 7 months ago by geri.
    #676
    hoopty
    Participant

    I have and they match exactly

    #678
    hoopty
    Participant

    I have achieved almost success.
    The problem occurred because I have user profiles on my D drive and it was installing PlatformIO stuff on C:.

    Anyway it compiles and then after linking it says it won’t fit on the flash by 26 bytes.

    UGH

    Any ideas? Anybody?

    Linking .pio\build\featheresp32\firmware.elf
    Retrieving maximum program size .pio\build\featheresp32\firmware.elf
    Building .pio\build\featheresp32\firmware.bin
    Checking size .pio\build\featheresp32\firmware.elf
    Advanced Memory Usage is available via “PlatformIO Home > Project Inspect”
    RAM: [== ] 22.1% (used 72456 bytes from 327680 bytes)
    Error: The program size (1507354 bytes) is greater than maximum allowed (1507328 bytes)
    Flash: [==========*** [checkprogsize] Explicit exit, status 1
    ] 100.0% (used 1507354 bytes from 1507328 bytes)
    esptool.py v3.0
    ================================================ [FAILED] Took 23.75 seconds ================================================The terminal process “C:\Users\b1dx9\.platformio\penv\Scripts\platformio.exe ‘run'” terminated with exit code: 1.

    Terminal will be reused by tasks, press any key to close it.

    #695
    HendrikV22
    Participant

    Good day,

    I’m having the same challenge as @hoopty. I’ve tried to change the database to huge_app.csv structure, but have noticed that this table has less information than the original partitions.csv structure… From what my instinct tells me is that I will loss functionality due to less data being stored to the table?

    How can we remediate this error:
    Advanced Memory Usage is available via “PlatformIO Home > Project Inspect”
    RAM: [== ] 22.1% (used 72456 bytes from 327680 bytes)
    Flash: [===Error: The program size (1507442 bytes) is greater than maximum allowed (1507328 bytes)
    ===*** [checkprogsize] Explicit exit, status 1
    ====] 100.0% (used 1507442 bytes from 1507328 bytes)

    Regards

    #696
    hoopty
    Participant

    Hendrik,

    Hopefully I can be of some help now.

      First are you using Git as in the video to download the code. It is important to use that instead of a straight download

    Git grabs merged code and downloads all new or modified code.

    uninstall whatever you installed
    remove any remnants of previous attempts including the stuff in your profile under c:\users\Username\ it might be under appdata which is a hidden folder
    (look for stuff relates to vscode and platformIO. delete them)

    Watch the video.

    there are specific versions that Matt uses. Git will not matter and Tortoise Git is only one version
    watch the whole video and pause as you do the steps. I missed step in my config.
    2.2.1 for PlatformIO
    VSCODE you have to search for previous versions. 1.5.2.1 I had trouble with so I used 1.5.4.x

    Once Platform IO is installed you can click on the gear icon and change the version

    DO NOT forget to setup the platform inside PlatformIO

    Try it now.

    #698
    HendrikV22
    Participant

    Hi hoopty,

    Thank you for the prompt resonse. It is much appreciated.

    Your recommendation worked. It seems that the platform version was the culprit… So the program compiled and I’m reday to move onto the next step.

    Once again, thank you very much for your assistance. It is greatly appreciated.

    Regards

    #712
    hoopty
    Participant

    What do you know about Android apps and compiling with gradle?

    I am trying to get the app compiled and lets face it, when it comes to these tools, I’m a loser. LOL

    Any help would be great though.

    #750
    HendrikV22
    Participant

    Hi @hoopty,

    Sorry for the loooooong overdue response – I was away for work etc….

    No, my knowledge is quite limiting when it comes to app development. I’m almost at the point to test the app (still trying out how to finish the initial setup phase).

    What eroor are you getting when trying to compile?

    Regards

Viewing 17 posts - 1 through 17 (of 17 total)
  • You must be logged in to reply to this topic.