Forum Replies Created

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • in reply to: Sandify Patterns #847
    HendrikV22
    Participant

    Hi Guys,

    Bumping this post to see if anyone maybe have a possible solution or are experiencing the same challenge?

    Kind Regards

    in reply to: Stepper Motor Disable #839
    HendrikV22
    Participant

    Hi dfronek,

    I still did not manage to get this solved. I tried to review the code in visual Studio but coding is not my strong point… only basic c++ (Adruino coding for me). I’m going to ask one of our programmers at work to see if they can assist with understanding the code and see why this is happening. I’m experiencing some delays as we are all working from home due to the Covid pandemic and trying to have this discussion over Zoom makes it a bit challenging.

    will keep you updated if there are any developments.

    in reply to: Stepper Motor Disable #837
    HendrikV22
    Participant

    Good evening dfronek,

    I’m having similar issues… after a pattern is drawn, the ball seems to be moving in small increments over time…. which at the end result in influencing the final pattern look…. I’m trying to play with the parameters on the bot configuration but no success so far….

    Kind Regards

    in reply to: Which optical end stop switches #836
    HendrikV22
    Participant

    Good evening klwill1192,

    I Used almost the same optical sensors I bought from Banggood:
    Optical Endstop Limit Switch Sensor with 1M 3Pin Cable for 3D Printer

    Please note that the signals of these ones are inverted… so you have to change the homing string in the motor configuration. MattG helped me to rectify this problem and it is on this form explained in detal. Please have a look.

    Kind Regards

    in reply to: Config Setup #831
    HendrikV22
    Participant

    Good evening dfronek,

    Thank you for the prompt response. It is appreciated.

    I’m not sure I’m following your last recommendation… Are you referring to the Drive M1A and M1B ports (referring to the electrical diagram shown on the DIY Kinetic Art table form of MattG) to be swopped?

    So, I have tried to swop the wire terminals at the drive ports M1A and M1B as well as M2A and M2B but it seems like it is not working.

    At the moment I can only draw 1 partial pattern and that is the pattern by Juggers website called “Spiral 4”. It starts with the spiral and is drawing it really nicely, but as soon as it comes to the end it buggers up the whole pattern.

    With other patterns, it doesn’t even remotely resemble the patterns when it draws. I’m struggling to upload photos to this form as when I use dropbox links the form doesn’t want to post it…

    Will it be possible (if you are willing) to send me a mail to my pvt email address hendrik.venter1@gmail.com so that I can share photos of what my bot is currently drawing and maybe share a pattern you have that works to see if my bot can draw the same pattern?

    Kind Regards

    in reply to: Config Setup #827
    HendrikV22
    Participant

    Hi All,

    So, I believe this falls under the Config section as I’m having challenges with drawing patterns and .the files….

    I tried to create a board explaining my challenges with links directing to Dropbox but I keep on getting the “This topic is pending moderations” after posting…. and after some while… “This Page doesn’t exist” … which is Weird….

    So, third try without any links….

    The sand table is finally up and running and drawing some patterns… well…. weird patterns…. The lines doesn’t conform to any possible shape applicable to the corresponding pattern being drawn (random zig-zag lines when a circle is expected).

    I tried numerous patterns downloaded from the web (the files) however, it seems that the program is reading the code wrong?

    The pattern it draws is random lines that don’t make sense… No neat or formal pattern at all…

    The ONLY pattern I could find that is working on the table is only ONE of the Spiral patterns on the Juggers website called “Spiral 4”

    This proves that the bot can read a pattern.

    Does anyone else experience the same issue? Or, does anyone have a pattern I could try that they know is working on their setup? My email address is hendrik.venter1@gmail.com

    I have uploaded all of the patterns I have multiple patterns loaded onto a dropbox folder which I would like to share with the group for testing but it seems that the dropbox links posted on the thread cause hiccups…

    Here is a manual paste of the link to the dropbox folder:

    Please really looking for assistance here.

    Kind Regards

    in reply to: Homing Strings #767
    HendrikV22
    Participant

    Hi Matt,

    Thank you for the great assistance. I must say, this forum is the first where prompt responses are experienced and help is given.

    The final end result was… Yes… It was the signals from the sensors that were inverted. So I had to change the N and n in the string. After changing it, arm A stopped after the optical switch was deactivated and arm B could home properly.

    I couldn’t find the exact optical sensors which you used, so ordered through banggood the optical switches. Also, for the rest of the people on the forum, I also ordered the Anet A8 plus printer through banggood for this project and all parts were printed with it. Quite happy with the quality compared to the price paid for it.

    Now that I know the bot is working 100% I’m ready to start building the table.

    Now I’m truly excited!

    Thank you again.

    Kind regards

    in reply to: Homing Strings #765
    HendrikV22
    Participant

    Hi Matt,

    Thanks for the information. It is much appreciated.

    so I compared the setup according your setup and yes, it is the same which is comforting to know.

    I did find the root cuase for the problem but not sure how to remediate it.

    So, what causes arm B from ingnoring its corresponding sensor and keeps on rotating? IT IS ARM A OPTICAL SENSOR THAT IS STILL ACTIVATED!

    So, How I tested this was the following:

    1. I activated the homing position.
    2. Before Arm A could reach the home position, I manually activated its sensor. This causes Arm A to stop and arm B started to rotate (with the first optical sensor for Arm A not acivated anymore).
    3. I activated arm B optical senos manually and it stopped. Which was great to experience.

    4. Then I resetted the whole system and rotated the arms to the 11:00 position.
    5. I activated the homing sequence and waited until Arm A activated the optical switch. It did, arm A automatically stopped and Arm B automatically started to rotaed. HOWEVER, Arm A’s optical switch is still Activated (green light still on). while the optical switch is still activated, the second optical switch for Arm B is ignored….

    So, what I believe would be the solution is the rotate Arm A for x amount further once optical switch is activated before it is stopped (so that optical switch for arm A is deactivated) before proceding to the next homing sequence for Arm B.

    I have played with the A+5000n;B-5000; Settings but it seems that I’m doing something wrong… I’m not getting the additional split second rotation after the switch is activated.

    Will you be able to assist please?

    Kind Regards

    in reply to: Homing Strings #759
    HendrikV22
    Participant

    Hi Matt,

    sorry I forgot to include the homing string, but as mentioned the homing string is the one that was posted on the forum as per your description. Also, the software that was loaded onto the bot was the version from Github.

    Kind Regards

    in reply to: Homing Strings #758
    HendrikV22
    Participant

    Hi @Matt G,

    Thank you for the prompt response. It is much appreciated. Ok, so let’s start from the top:

    1. I reviewed your comments and made the changes to the code as recommended to ensure that A is moving the bottom arm and B is moving the top arm. This has been tested and the motors is connected and working accordingly.

    2. I turned the power off from the unit and restarted everything (the “Have you tried to switch it on OFF and On again” sequence).

    3. On startup, everything seems to be booting up nicely. On the terminal screen I see I’m connected to the WIFI and through the browser I can access the Robot configurator (UI). I can see that the memory card is reading accordingly (32Gb card) and can upload/delete paterns onto the bot. Under the “RobotConfig” row I can see the corresponding code I uploaded as stipulated in the “DIY Kinetic Sand Table Art” as described by you.

    4. I have then set the arms to be at the “11:00” clock position to test whether both the Bottom and Upper arm can be homed automatically.

    5. After that, I pressed the “Home All” button.

    6. The Bottom arms starts to home and as soon as the optical limit switch is activated (the sensor located at the bottom of the bot) the bottom arm stops to move and the Upper arms starts to move.

    7. However, the Upper arms keeps on rotating through the optical sensor even when the sensor is activated (The light of the sensor comes on).

    8. I then thought the sensor is broken and replaced it with a new sensor. However, on activating the homing position again, the Upper arm once again ignored the sensor and keeps on rotating.

    9. I then thought it may be that the signal wire of the sensor is damaged and that the signal is not getting through to the processor. How I tested this was the following:
    * I positioned the arms again to the 11:00 position and activated the homing sequence.
    * Before the Bottom arm could activate the bottom sensor, I manually activcated the upper arm sensor with a piece of plastic – The result was that the Bottom arm stopped moving and the Upper arm did not start to move. According to my understanding is that this is correct. The reason being is that the only possible reason for the Upper sensor to be activated through the auto homing sequence, both the Upper and Bottom arms should be in the home position. Therefore, confirming that both the sensors are working and that the software is picking it up.

    What I do not understand is why the second sensor is ignored when the homing sequence is activated, the Bottom arm gets it auto home position but the Upper arms keeps on rotating….

    I made a video to show what is happening and stored it under the following dropbox link – If you could please have a look and see if something is wrong? I would appreciate it.

    https://www.dropbox.com/sh/jw6l9ahfqmbfo7v/AAAaefnqsJ0Ds3oQRAcNp9TIa?dl=0

    Otherwise, If you have another way for me sharing info to you which might help assist in finding the problem I would gladly do so.

    Kind Regards

    in reply to: Homing Strings #756
    HendrikV22
    Participant

    Hi all,

    so I want back to the drawing board….

    1. Deleted all files from my computer
    2. downloaded the latest version of the RBotFirmware from github
    3. reloaded software into the Visual Studio platform
    4. upload new RBotFirmware onto the CPU

    I’m still getting the same issue…. The first step of the homing function works great, the arm rotates and as soon as the optical light has made contact the second arms start to rotate. however, it keeps on kssing the homing position – even though the optical switch is activated (green light comes on).

    I tested the switcha again by activating the homing function and manually activating the second opticl switch with a piece of plastic – Both arms stops to rotate as if it recognises that it is at the home position – confirming that the switch is working….

    Is there someone that can assist me on the programming on where to find the function of the second limit switch? I do not have preally programming skills (apart from REALLY basic Arduino programming)?

    in reply to: Homing Strings #755
    HendrikV22
    Participant

    Hi guys, I’m really struggling with the homing function of the bot. So, what happens is the following:

    I start the unit by pressing the ‘home all’ button.

    The main arm (upper arm) starts to rotate until the optical limit switch at the bottom is made – the green light turns on and the arms stops rotating, therefore confirming it is in the ‘home’ position

    The second arm (lower arm) automatically then starts to rotate and when it makes the optical switch (the green light of the switch turns on) it keeps on rotating. Therefore missing the home position. I have also changed the switch with another switch and is still skipping the homing position when the light goes on….

    Here is the part that tickles my brain….

    When I start the homing process and use a piece of plastic arm to trigger the lower arm optical limit switch, all arms stops to rotate. This confirms that the electronics is picking up the lower arm optical switch and therefore something else is causing the problem.

    Is there someone that experienced the same problem or can guide me in rectifying this?

    in reply to: Connecting to Wifi #752
    HendrikV22
    Participant

    Nevermind guys…

    Rooky programming mistake…. the “>” should not have been part of the command….LOL

    Thanx anyways!

    in reply to: Error when compiling #750
    HendrikV22
    Participant

    Hi @hoopty,

    Sorry for the loooooong overdue response – I was away for work etc….

    No, my knowledge is quite limiting when it comes to app development. I’m almost at the point to test the app (still trying out how to finish the initial setup phase).

    What eroor are you getting when trying to compile?

    Regards

    in reply to: Error when compiling #698
    HendrikV22
    Participant

    Hi hoopty,

    Thank you for the prompt resonse. It is much appreciated.

    Your recommendation worked. It seems that the platform version was the culprit… So the program compiled and I’m reday to move onto the next step.

    Once again, thank you very much for your assistance. It is greatly appreciated.

    Regards

    in reply to: Error when compiling #695
    HendrikV22
    Participant

    Good day,

    I’m having the same challenge as @hoopty. I’ve tried to change the database to huge_app.csv structure, but have noticed that this table has less information than the original partitions.csv structure… From what my instinct tells me is that I will loss functionality due to less data being stored to the table?

    How can we remediate this error:
    Advanced Memory Usage is available via “PlatformIO Home > Project Inspect”
    RAM: [== ] 22.1% (used 72456 bytes from 327680 bytes)
    Flash: [===Error: The program size (1507442 bytes) is greater than maximum allowed (1507328 bytes)
    ===*** [checkprogsize] Explicit exit, status 1
    ====] 100.0% (used 1507442 bytes from 1507328 bytes)

    Regards

Viewing 16 posts - 1 through 16 (of 16 total)